VLANs con DHCP (Cisco)

Sencillos pasos de cómo configurar una red con varias VLANs y tener DHCP.

Ejemplo de cómo debe de estar configurado el router

Se crearon 3 subinterfaces dentro de la interfaz FA0/0 del router, para esto primero se le asigna la encapsulación seguida del número de la VLAN, la primera es la nativa por default aunque se puede cambiar a otra.

interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.10.1 255.255.255.0

interface FastEthernet0/0.2
encapsulation dot1Q 20
ip address 192.168.11.1 255.255.255.0

interface FastEthernet0/0.3
encapsulation dot1Q 30
ip address 192.168.12.1 255.255.255.0

Después se crean las IP de exclusión y los pool

ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.11.1 192.168.11.10
ip dhcp excluded-address 192.168.12.1 192.168.12.10

ip dhcp pool vlan1
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1

ip dhcp pool vlan20
network 192.168.11.0 255.255.255.0
default-router 192.168.11.1

ip dhcp pool vlan30
network 192.168.12.0 255.255.255.0
default-router 192.168.12.1

Eso es todo lo que hay que hacer en el router, ahora vamos con el Switch principal o server.

El FA0/1 debe de estar en troncal, FA0/2 está automaticamente en la VLAN 1 y FA0/3 y 0/4 están en su correspondiente VLAN. Un switch está en modo vtp server por default.

Ahora hay que poner los otros switches en modo client: entramos al modo de configuración global y tecleamos “vtp mode cliente” (sin las comillas).

Y obviamente solo resta asignar las pc’s a cada switch client y que el IP se proporcione mediante DHCP. Eso es todo.

About these ads

7 comentarios to “VLANs con DHCP (Cisco)”

  1. pepe Says:

    gracias, muy bie explicado

  2. psychologeeksquad Says:

    De nada, cualquier duda puedes exponerla en el apartado de dudas y sugerencias.

    http://psychologeeksquad.wordpress.com/dudas-y-sugerencias/

  3. Pastor Cortes Says:

    muy buena explicacion… gracias

  4. Ezequiel L. Says:

    Tengo 2 consultas al respecto:
    1) ¿no es conveniente que la vlan1 se desactive y se utilice otra vlan como nativa?
    2) ¿el dhcp para la vlan nativa (en tu caso 1), es necesario?

    • fabioolamuak Says:

      La mejor práctica indica que se realice el cambio de la vlan nativa, sabemos que por default en los equipos cisco la vlan nativa es la 1, sólo que al momento de cambiarla en un Switch debes asegurarte que en los demás Switches de tu dominio también se realice el cambio, de otro modo no se realizará el intercambio de información correctamente.

      Además el DHCP para la vlan nativa no es necesario si asignas IP a los Switches de manera estática,

      Saludos!

  5. Esaes Says:

    Te veo muy dentro ahora mismo.

  6. osvaldo Says:

    buen dia muy bien explicada, pero yo estoy realizando una practica donde los dhcp no estan en las redes directas a asignar ip, es decir “pc -router ——router – servirdor” ya coloque el ip helper-address para que busque el servicio en la otra red pero no me manda ninguna ip de respuesta , cabe destacar la pc y el servidor estan en 2 segmentos de red distintos, ya esta configurado el dhcp con el pool correspondiente,
    gracias de antemano


Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

%d personas les gusta esto: